Seite 1452 von 1452 ErsteErste ... 45295213521402144214481449145014511452
Ergebnis 21.766 bis 21.773 von 21773

Thema: BASE: FRAGEN & FEEDBACK (inkl. Fehlermeldungen)

  1. #21766
    Registrierter Benutzer Avatar von Ramkhamhaeng
    Registriert seit
    19.07.10
    Beiträge
    7.609
    Ich glaube, ich hatte dir schon mal geschrieben, dass man einfach nur
    ...\Civ4BeyondSword.exe ini=[Name].ini in die Verknüpfung für den Spielstart schreiben muss…
    Auf Bat-Scripte kann man also verzichten.

    Wichtig ist dabei, dass die ini-Datei im gleichen Ordner wie die Exe liegt.

  2. #21767
    Sir
    Registriert seit
    22.11.01
    Ort
    Deutschland / Europe / Terra / Sol / Milkyway
    Beiträge
    482
    Zitat Zitat von Ramkhamhaeng Beitrag anzeigen
    Ich glaube, ich hatte dir schon mal geschrieben, dass man einfach nur
    ...\Civ4BeyondSword.exe ini=[Name].ini in die Verknüpfung für den Spielstart schreiben muss…
    Auf Bat-Scripte kann man also verzichten.

    Wichtig ist dabei, dass die ini-Datei im gleichen Ordner wie die Exe liegt.
    Und ich hatte bereits darauf hingewiesen, dass das bei mir eben NICHT so funktioniert.

    Jedenfalls ist die Batchdatei in Zweifelsfall die immer funktionierende und sicherere Variante, ganz besonders, wenn man mit mehreren Mods spielt, die alle ihr eigenes Setup und Aufrufe haben und sich ggf. gegenseitig killen. Hast Du z.B. BASE und ROM installiert und rufst ROM mit dessen Starttool auf, ist der BASE-Aufruf im Mülleimer. Nachfolgende Starts werden immer nur von der eigenen ini gelesen.

    In so fern schadet es wohl nicht, wenn auch eine Lösung für nicht-default-Installationen veröffentlicht wird, oder?

    (Und vom Handling her sehe ich keinen Unterschied, ob ein Shortcut auf einer Batchdatei oder auf der Ini liegt. Schnell gemacht und auch nur 1 Klick dann)

    Übrigens: Bei mir speichert BtS die ingame gemachten Änderungen in der E:\Documents\My Games\Beyond the Sword\CivilizationIV.ini und nicht einer E:\Civ_4\Beyond the Sword\\CivilizationIV.ini (Das hat bei der Installations seinerzeit BtS selbst so gemacht, in E:\Civ_4\Beyond the Sword, wo die EXE liegt, gibts gar keine .ini und hat es noch nie gegeben. - Warum auch die Defaultvorgabe bei BASE-Intallation bei mir nicht funktionierte) - Eine ggf. in E:\Civ_4\Beyond the Sword abgelegte .ini wird schlichtweg ignoriert.
    Geändert von Dreifels (Heute um 01:48 Uhr)

  3. #21768
    Registrierter Benutzer Avatar von Ramkhamhaeng
    Registriert seit
    19.07.10
    Beiträge
    7.609
    Zitat Zitat von Dreifels Beitrag anzeigen
    Und ich hatte bereits darauf hingewiesen, dass das bei mir eben NICHT so funktioniert.
    [...]

    Übrigens: Bei mir speichert BtS die ingame gemachten Änderungen in der E:\Documents\My Games\Beyond the Sword\CivilizationIV.ini und nicht einer E:\Civ_4\Beyond the Sword\\CivilizationIV.ini (Das hat bei der Installations seinerzeit BtS selbst so gemacht, in E:\Civ_4\Beyond the Sword, wo die EXE liegt, gibts gar keine .ini und hat es noch nie gegeben. - Warum auch die Defaultvorgabe bei BASE-Intallation bei mir nicht funktionierte) - Eine ggf. in E:\Civ_4\Beyond the Sword abgelegte .ini wird schlichtweg ignoriert.
    Wir drehen uns im Kreis, aber ich will das so nicht stehen lassen.

    1. Ich gehe nicht davon aus, dass du eine komplett andere Exe hast als alle anderen.
    2. Das CivilizationIV.ini unter My Games angelegt wird ist normal. Es sieht zwar so aus, aber es widerspricht meinen Aussagen nicht.
    3. Wenn beim Start von Civ4 mit ini=...-Parameter keine Datei im Programmverzeichnis angelegt wird, liegt es in der Regel an fehlenden Schreibrechten. Kannst du mit deinem Benutzeraccount in dem Verzeichnis Dateien anlegen?

    4. Die Bat-Skript-Lösung läuft bei dir, aber leider, in der von dir geposteten Variante, nicht bei allen Nutzern. Zum einen fehlt die Angabe wo die Dateien angelegt werden sollen. Ok, das kann man leicht beheben
    Zum anderen führt die Zeile 'CivilizationIV.ini' im Allgemeinen nicht zum Start von Civ4:BTS. Im Allgemeinen müsste da die Exe direkt aufgerufen werden (+ Wahl des Working directory's ).

    5. Eigentlich müsstest du die Ini nach dem Programmende von Civ4 auch wieder zurück kopieren, um die Änderungen zu behalten. Um so was muss man sich bei der anderen Variante keine Gedanken machen.

  4. #21769
    Civ4 BASE Coder Avatar von rucivfan
    Registriert seit
    10.07.11
    Ort
    Antarktika
    Beiträge
    18.446
    Zitat Zitat von Dreifels Beitrag anzeigen
    Wichtig ist dann noch, dass in der .ini die Zeile 138 angepasst ist
    Code:
    Specify a Mod folder (Mods\Mesopotamia), '0' for none
    Mod = Mods\BASE 6.3
    Woher nimmst du diese merkwürdigen Zeilenangaben? Bei mir ist das Zeile 14 und das war noch nie anders.

    Deine Lösung ist für andere nicht hilfreich. Sie funktioniert nur einmal aber nicht bei wechselnden Starts wie Ramk schon anmerkte. Alle Einstellungen gehen ohne zurückversetzen der inis verloren.
    Geändert von rucivfan (Heute um 06:24 Uhr)

  5. #21770
    Registrierter Benutzer
    Registriert seit
    08.04.04
    Beiträge
    4.684
    Kann man die ganzen Programmier-Diskussion nicht auslagern? Ich hatte the Fred immer so verstanden, dass man hier Fragen zum Spiel oder Feedback zu BASE geben kann. Mittlerweile ist das ja nur noch ein Programmierer-Stammtisch.

  6. #21771
    Civ4 BASE Coder Avatar von rucivfan
    Registriert seit
    10.07.11
    Ort
    Antarktika
    Beiträge
    18.446
    Zitat Zitat von Loudhy Beitrag anzeigen
    Kann man die ganzen Programmier-Diskussion nicht auslagern? Ich hatte the Fred immer so verstanden, dass man hier Fragen zum Spiel oder Feedback zu BASE geben kann. Mittlerweile ist das ja nur noch ein Programmierer-Stammtisch.
    Ähm, von was redest du? Das hier ist keine Programmierer-Diskussion. Es geht hier um nicht weniger als um die Antwort zu der Frage von leolo. Zumal das Thema für alle wichtig ist, wie man BASE ohne Einstellungsverlust starten kann.
    Geändert von rucivfan (Heute um 10:40 Uhr)

  7. #21772
    Registrierter Benutzer
    Registriert seit
    08.04.04
    Beiträge
    4.684
    Zitat Zitat von rucivfan Beitrag anzeigen
    Ähm, von was redest du? Das hier ist keine Programmierer-Diskussion. Es geht hier um nicht weniger als um die Antwort zu der Frage von leolo. Zumal das Thema für alle wichtig ist, wie man BASE ohne Einstellungsverlust starten kann.
    Kann man so komplexe Fragen denn nicht einfach woanders diskutieren und nach der Lösung hier beantworten? So wir bei mir, als ich nach dem Vergößeren der Karte gefragt habe. Das zerhackt nicht alles so unglaublich.

    Ach ja, war das die Frage von Anfang Dezember letzten Jahres? Man findet in den Posts kaum noch den Ursprung einer Frage . Wären die ganzen XML-Diskussionen nicht besser im Coder's Lair aufgehoben? Den Fred habt ihr damals doch sicher deswegen eingeführt.

  8. #21773
    Civ4 BASE Coder Avatar von rucivfan
    Registriert seit
    10.07.11
    Ort
    Antarktika
    Beiträge
    18.446
    Zitat Zitat von Loudhy Beitrag anzeigen
    Kann man so komplexe Fragen denn nicht einfach woanders diskutieren und nach der Lösung hier beantworten? So wir bei mir, als ich nach dem Vergößeren der Karte gefragt habe. Das zerhackt nicht alles so unglaublich.
    leolo hat halt hier gefragt und ich finde das hier passend.

    Ach ja, war das die Frage von Anfang Dezember letzten Jahres? Man findet in den Posts kaum noch den Ursprung einer Frage .
    Das ist kein BASE-Problem, sondern passiert in jedem Faden.

    Wären die ganzen XML-Diskussionen nicht besser im Coder's Lair aufgehoben? Den Fred habt ihr damals doch sicher deswegen eingeführt.
    ini-Datei hat rein garnichts mit XML zu tun und schon garnichts mit Coden. Dort stellst du deine Auflösung und Co ein bzw werden dort die Ingame-Einstellungen gespeichert.
    Geändert von rucivfan (Heute um 12:19 Uhr)

Seite 1452 von 1452 ErsteErste ... 45295213521402144214481449145014511452

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •