Ergebnis 1 bis 5 von 5

Thema: Ein Problem mit C2C

  1. #1
    Registrierter Benutzer
    Registriert seit
    24.10.16
    Beiträge
    3

    Civ4 Modifikationen und Szenarien Ein Problem mit C2C

    Hallo liebe Kameraden!
    Ich habe leider ein Problem mit der Modifikation von Caveman to Cosmos. Zwar kriege ich den Mod zum Laufen und kann im Spiel auch Einheiten kontrollieren, aber ich habe ein sehr großes Problem, das ein längeres Spiel praktisch unmöglich macht. Folgendes: Diese Balken oben und unten, mit den ´Befehlen für Einheiten und dem ganzen Zeug ist weg. Ich habe schon versucht, die Bildschirmgröße auf Maximum zu stellen und ich habe schon bei den FAQ bei C2C nachgelesen. Dort stand sogar was zu dem Problem, aber sonst konnte ich damit nichts anfangen. Kann mir hier vielleicht einer helfen?

    Gruß, Panzerkira

  2. #2
    Moderator Avatar von Kathy
    Registriert seit
    11.10.07
    Beiträge
    11.494
    Mod-Aktion: Faden verschoben.
    Der Forum "Modifikationen" ist etwas unklar benannt, es dient zum Posten fertiger Modifikationen und zur Diskussion einer dort veröffentlichen Mod.
    Allgemeine Fragen - und darunter fasse ich auch Fragen zu Mods, die nicht hier, sondern bei den Civfanatics bereitgestellt wurden - sollten besser im allgemeinen Forum gestellt werden.


    Ich kenne den Mod leider nicht.
    Kannst du vielleicht den Teil aus den FAQ hier einmal zitieren, damit wir es uns anschauen können? Für mich klingt das nach einem Python-Fehler, der die Anzeige beeinflusst.
    Hast du sichergestellt, dass die die richtige Version des Mods hast, die zu der Civ-Version passt? Ein Mod für 3.12 passt nicht zu 3.19.
    Ansonsten: Aktivier einmal in der Civ4.ini die Python Exceptions (Hide Python Exceptions auf 0 setzen). Die Fehlermeldungen werden dir vielleicht nicht viel sagen, aber uns hier bestimmt.
    That's why I am here: Mein Mod
    Mehr Technologien, mehr Einheiten, mehr Zivilisationen, mehr Gebäude

    Die aktuelle Story zum Mod:
    Kathys Mod: The british Empire - United Kingdom zum Dritten

    Alte Stories zu alten Versionen:
    Alte Storys

  3. #3
    Registrierter Benutzer
    Registriert seit
    24.10.16
    Beiträge
    3
    Erstmal danke für deine Antwort. Bei den FAQ steht das so:
    1.) I have Civ4 Complete and/or Vista and I've installed your modpack but when I play a game I can see the map & my units but not any interface or command buttons. Why is this & how do you fix it?
    This is a problem that can happen with modpacks that include the BUG Mod and Civ4 Complete installations. Basically, Civ4 Complete places its registry entries in a different location than the normal Civ4 installation & thus causes problems with the BUG Mod.

    The fix involves editing your Windows registry as described in the following link (Post#12):

    http://forums.civfanatics.com/showth...te#post6367044

    Da ist jedenfalls dieser Link, aber mit den dortigen Struktionen kann ich nicht wirklich was anfangen(Wohl auch, weil mir diese Bilder irgendwie nicht angezeigt werden).

  4. #4
    Registrierter Benutzer Avatar von Ramkhamhaeng
    Registriert seit
    19.07.10
    Ort
    Aralkum
    Beiträge
    8.451
    Hallo Panzerkira,

    mit den Infos können wir dir schon eher weiter helfen. Das die Bilder in dem Thread fehlen ist ärgerlich, da sieht man dass es sehr hilfreich ist, die Dinger direkt im Forum hochzuladen

    Die Ursache scheint zu sein, dass der Setup-Assistent, den du bei der Installation von C2C verwendest, für ein Teilmodul (BUG-Mod) nicht das passende Verzeichnis findet. Bei der Complete-Version wurde wohl ein Registry-Eintrag vergessen, der bei anderen Varianten dabei ist.
    Ich habe leider nur ein Bild für Civ4:Colonization parat, aber das sollte bei dir ähnlich sein.

    0. Suche das Installation-Verzeichnis von Civ4 raus. Das ist das Verzeichnis, in dem Civ4BeyondSword.exe liegt.
    1. Starte den Registry-Editor, z.B. per [Win]+R und dann regedit eintippen
    2. Hangle dich zu dem Eintag des Spiels, ganz unten auf dem Bild sieht man ungefähr wo das bei dir sein sollte.
    Bild

    3. Dort wird dann wahrscheinlich der Eintrag "INSTALLDIR" fehlen. Öffne das Kontextmenü und wähle Neu>Zeichenfolge. Erstelle dann INSTALLDIR und trage den Ordner aus Punkt 0 ein.
    Bild


    4. Versuche dann eine neue Installation von C2C.
    5. Falls das nicht hilft bitte dem Tipp von Kathy folgen. Dazu unter [Eigene Dateien]\My Games\Beyond the Sword\ die Datei CivilizationIV.ini öffnen und
    beim Punkt HidePythonExceptions den Wert auf 1 setzen. Danach sollte im Spiel eine (aussagekräftige?) Fehlermeldung erscheinen.
    Angehängte Grafiken Angehängte Grafiken

  5. #5
    Registrierter Benutzer
    Registriert seit
    24.10.16
    Beiträge
    3
    Wow das hat geholfen Vielen Dank für deine Unterstützung!

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •